Schlagwort-Archive: Hardware

Eine Webcam ist keine Scheibe

*Flomp* – Die Schnäppchenfalle hat zugeschlagen – Reichelt macht gerade Ausverkauf mit einer USB Motion-Webcam von Anubis/Typhoon. 180° auf der X- und 60° auf der Y-Achse sorgen mit flüssigen 30FPS bei dem von 52 auf 11EUR reduziertem Modell für einen ordentlichen Überblick. Einen Haken hat dieses Sonderangebot natürlich: Die Auflösung ist mit 640×480 Nativ nicht mehr zeitgemäß, daran kann auch das Interlacing auf 1280×960 sowie der 4x-Digitalzoom nichts ändern. Die Bildqualität ist auch daher nicht mit modernen Kameras zu vergleichen. Bei Innenaufnahmen liegt sie jedoch deutlich vor vielen Onboard- und Billigkameras, kommt Sonnenlicht ins Spiel trüben Schärfeverluste an den Ecken den Eindruck massiv. Um Verrutschen zu vermeiden befindet sich eine Gummischicht unter der Kamera.
18465

Erster Eindruck unter Windows XP
Hauptanwendungsbereich dürfte wohl der private Videochat darstellen – hier punktet die Kamera mit ihrer automatischen Nachführung und dem integriertem Mikrofon. Die Kamera ist dank USB2.0 schnell installiert, das Mikrofon sollte mit seinem separaten 3,5er Klinkenstecker ebenfalls keine Probleme verursachen. Die Windows-Treiber lassen sich mit den üblichen Handgriffen einrichten und verlangen nach einem Neustart – in meinem Falle lief es auch ohne.
Startet man eine Videoanwendung wird automatisch ein weiteres Fenster aus seiner Schlummerposition in der Systray erweckt und bietet manuelle Bewegungsfunktionen – auch lässt sich hier die Automatik und Zoom direkt konfigurieren. Nur einen Klick weiter lassen sich neben Helligkeit, Kontrast, Sättigung, Gamma und den weiteren Standardoptionen auch manuell die Belichtungswerte, Weißabgleich und Flackerunterdrückung einstellen. Ohne Konfiguration stellt sich die Automatik in den meisten Situationen gut ein, bei Außenaufnahmen fiel die Belichtung hier jedoch etwas zu grell aus.
Die automatische Nachführung soll das Gesicht immer im Bildmittelpunkt halten – praktisch für Konferenzen. Stellt man vor der Kamera keine Laufszenen nach trifft die Software auch meistens den Kopf und beißt sich nur selten an anderen Körperteilen fest.

Stolperfalle Bewegung
Die Bewegungsfunktion der Kamera ist zwar praktisch, aber nicht immer optimal: Die Mittelstellung wird erreicht, in dem immer ein kompletter Schwenk gemacht wird, so erkennt die Kamera ihre Grenzen neu und schätzt die Mitte. Bei der manuellen Steuerung ist die X-Achse invertiert, was doch schnell verwirrt. Auch soll es nach Angaben im Netz massive Probleme unter Windows Vista und Windows 7 geben – hier scheint die Software Bewegungsbefehle etwas eigenwillig zu interpretieren. Eine letzte Warnung noch: Vorsicht im Handbuch, hier stößt man auf einige Übersetzungsfehler, also erst denken und nich 1:1 Nachklicken.

Pinguin-Ball
Für mich interessant ist natürlich der Betrieb unter Linux. Die Kamera selbst identifiziert sich als

Product: USB 2.0 PC camera
Manufacturer: SQ Tech CO., LTD.

lsusb führt sie als

ID 2770:930b NHJ, Ltd

Laut Netz steckt dahinter ein sq930x-Chip, leider bestätigt sich diese Angabe nach meinem Kampf mit der Vieldrahttechnik im inneren des Balls. Hierfür existiert zwar ein V4L-Modul, dieses ist jedoch nur auf Keneln <2.6.24 lauffähig. Für neuere ist von einer Integration in gspca die Rede, aber bisher gibt es noch keine Codes dazu.
1846918473

Doppelte Leistung, reduzierter Verbrauch

Die Preise purzeln und mein PC schreit nach Updates. Seit heute schlummert ein (älterer) Quadcore unter dem Kühler meiner Workstation. Auf den ersten Blick kann ich nicht meckern: Leistungsmäßig hängt der Q6600 bei parallelen Prozessen meinen alten Pentium D930 locker ab und auch auf der Stromrechnung wird sich die neue CPU bemerkbar machen: Statt 170W sind nun im Leerlauf nurnoch knapp über 100W fällig. Selbst bei Vollast liegt er mit 160W unter dem Leerlauf des alten Systems. Gegen die 15W des Laptops natürlich noch immer recht viel, aber bei der Leistung ganz passabel – die Uptime des Laptops wird der PC auch wohl nicht erreichen.

Mein zweiter Versuch eine weitere Grafikkarte einzubinden ist hingegen Fehlgeschlagen. Momentan versorgen eine PCIe x16 GeForce 8600GT sowie eine PCI GeForce 5200 die 4 Monitore. Leider steht in dieser Kombination keine Hardwarebeschleunigung zur Verfügung – Arbeiten kann man zwar, aber wehe rutscht eine Flashwerbung durch. Die neue, zusätzliche 8600GT wird zwar im zweiten PCIx-Slot erkannt, dieser ist jedoch nur für SLI gedacht und beherrscht nicht die vollen 16 Lanes – Textmodus funktioniert so auf allen Monitoren, der X-Server hängt sich jedoch beim starten auf. Anscheinend gibt es aber tatsächlich keine Boards, die 2 vollwertige PCIe-x16-Slots anbieten :o.

Edit:
Hier mal ein Prozessorvergleich. Aufgabe war es den 2.6.28er Kernel mit meiner Config zusammen zu bauen. Die Sources lagen jeweils im RAM, Festplatten oder ähnliches sollten also keinen nennenswerten Einfluss gehabt haben.

Pentium D 930 Core2Quad Q6600
user 10m13.390s 6m27.980s
sys 1m12.909s 0m54.203s
real 5m56.789s 2m3.276s

Die reale Zeit hat sich also mehr als halbiert, die zudem geringere theoretische Rechenzeit dürfte sich durch die Verbesserungen der Befehlssätze ergeben.

Kampf gegen den LaserJet

Es war schon ein solides Gerät, der LaserJet 2100, welcher Ende der 90er auf den Markt kam. Fast 10 Jahre ist das Modell vor nun schon – aber weit entfernt von der Rente. Dummerweise hatte sich der manuelle Einzug verhakt – spätestens wenn man überspringende Zahnräder hört und Eisenteile aus dem Gerät fallen ist es Zeit für eine Reparatur. Die Abdeckungen ließen sich nach einigen Schrauben auch schnell Entfernen und auch die Problemursache – ein gebrochenes Plastikteil – war schnell ausgemacht. Nur was dann? Das Teil sitzt auf einer Eisenstange – auf der einen Seite ein Verschluss, auf der anderen das gesamte Getriebe – na toll. Hilft nix: Zerlegt, Plastikteil mit ostasiatischem Sekundenkleber behandelt, zusammengebaut. Klackern . Auseinander, Zahnrad gerichtet, zusammen. Rote Lampe. Auseinander, Motorkabel richtig eingesteckt, zusammen. Klackern. Das ganze lief noch einige Male bis der Drucker ohne Murren auf Bereit sprang. Erster Test stimmte mich auf zuversichtlich – das Papier aus der Kassette landete zielstrebig im Ausgabefach. Dann der wichtigerer Test – Manueller Einzug. Der soll demnächst Folien bedrucken um Platinen zu belichten. Warum er natürlich nicht funktionierte kann Murphy sicher erklären. Etwas genervt von fehlgeschlagenen Einzugsversuch gabs einen Tritt für den Drucker und – siehe da – er zieht das Papier. Offenbar ist das Zahnrad immer noch ein Stück zu weit weg und der Einzug brauch etwas Starthilfe. Ist zwar sicher nicht optimal, aber da ich ohnehin nicht so viel auf dem Fach drucke kann ich mit leben.
Nebenbei musste auch der Infrarot-Port des Druckers einen Testlauf ertragen. Dummerweise gibt es keine aktuelle Software mehr von HP, sodass meine Idee mit Drucken vom Handy wohl wegfällt

Bastelarbeiten zum Jahresende

Eine Woche Urlaub hinterlässt spuren. Der Schreibtisch hat sich in ein riesiges Steckbrett verwandelt und der Boden dürfte sich irgendwo unter der zentimeterdicken Schicht der Testverkabelung befinden. Obwohl die Post offenbar schon Weihnachtsurlaub hat und mir noch einiges an Hardware fehlt konnte ich doch einige Punke auf meiner Liste abarbeiten:

Zum einen habe ich den schwachen Dollar etwas ausgenutzt und meinem Server noch ein paar Festplatten spendiert. Neben dem bisherigem Terrabyte für die Daten (4x250GB, SATA-1, RAID 5 = effektiv 750GB) gesellen sich jetzt 2 weitere Terrabytechen ins Gehäuse (4x500GB, SATA-2, Controller PCI-X 64Bit, RAID 5 = effektiv 1,5TB) und erhöhen damit die Kapazität aller 13 Festplatten auf physikalische 3,1TB. OK, irgendwie muss ich noch einen Lüfter dabeizaubern – bei Volllast kratze ich an der 40°C-Marke. Zwar sind die Platten laut Datenblatt bis 60°C ausgelegt, aber man muss ja nichts riskieren.

1186811863

Nächster Punkt ist mein zusätzliches “Brandmeldesystem”. Zwar fehlt immernoch die endgültige Platine der Zentraleinheit, aber inzwischen hängen meine Rauchmeldeeinheiten in den Räumen, können lokal im Bandfall einen akustischen Alarm geben und liefern bereits Temperaturmesswerte an meinen Server, der fleißig Diagramme zeichnet. Die Stromversorgung läuft über ein überwachtes Schaltnetzteil, ist mit mehreren dezentralen Bleiakkus gepuffert, jeder Sensor hat eine separat abgesicherte Leitung und alle Sensoren werden (wenn die Zentraleinheit läuft) ständig auf korrekte Funktion überwacht.

Zwischendurch hat sich dann noch meine Workstation zu Wort gemeldet – ein RAID1 schützt vielleicht vor Festplattenausfällen, aber gegen Probleme des Dateisystems (ext3) ist auch das machtlos. 4 Stunden später lief ein neues Gentoo auf dem System und dank den letzten Updates klappt trotz 64Bit jetzt sogar Flash. UT ist natürlich auch drauf 😉

Meine Wetterstation närt sich langsam wieder einem funktionsfähigem Zustand – inzwischen konnte ich die Fehlfunktionen auf einen kaputten Sensor zurückführen. Zusammen mit dem Funksender können so jetzt wieder Temperatur und Luftfeuchte ermittelt werden. Auch der Luftdrucksensor müsste funktionieren, ist aber noch nicht kalibriert. Der Regensensor ist hardwareseitig auch fertig, hier fehlt noch eine passende Ergänzung Software. Gänzlich fehlen meine letzten Wunschsensoren für Wind und Sonnenenergie, die danach irgendwann mal in Angriff genommen werden.

Bei iSys bin ich noch nicht weiter. Zwar schau ich mir zwischendurch immer mal wieder einzelne Softwareteile an, aber auch hier warte ich noch auf meine Platinenbestellung, denn Softwaretest auf dem Steckbrett sind recht aufwändig.

Ansonsten herrscht das übliche Weihnachtsgeraffel – Geschenke organisieren etc. Nebenbei noch Zertifikate erneuern (ja, ich weiß, der IMAP-Server fehlt noch) und packen müsste ich natürlich auch noch…

RTFM, LogiLink

Standards sind toll – wenn sich mal Jemand dran halten würde. LogiLink zählt nach meinem ersten Eindruck offenbar zu den Firmen, die dies nicht immer tun. Grund für meine Meinung ist eine 5.1 Soundkarte “PC0027A”. Schaut man sich die Karte an sollte eigentlich alles klar sein: 2 Kerben am PCI-Stecker verkünden eine Universal-Karte, welche sowohl auf Systemen mit 5V als auch auf 3.3V-Boards verwendbar ist. Die Kerben wurden extra eingeführt, um ein Verwechseln unmöglich zu machen. Leider sind die Kerben an dieser Karte offenbar nur Dekoration: Während die Platine in meiner mit 5V ausgerüsteten Workstation ohne Probleme funktioniert war ein Einbau in meinen 3.3V-Rechner keine gute Idee: Ein kurzes Drehen des Lüfters und stille – das Netzteil vermeldet einen Kurzschluss. Inzwischen habe ich auch eine Vermutung warum: Auf der Karte wurden (sofern ich die PCI-Spez richtig interpretiere) die Leitungen mit festen 5V und jede, die je nach System 5V oder 3.3V führen, verbunden. In meinem Fall würde also die 3.3V und 5V des Netzteils gebrückt, was die Meldung des Netzteils erklären würde. Glück gehabt, dass auf dem Board nichts beschädigt wurde.

Ungeplante Migration

Uff, Was für ein Marathon. Eigentlich hatte ich am Freitag ja noch gute Laune, als der Postbote – passend zum freien Tag – meinen neuen Server durch die Tür schleppte. 2 Sockel mit je einem soliden Xeon 3.06GHz, 4GB RAM und netten Spielereien wie z.B. IPMI (aka mein BIOS kann TCP/IP) sollten wieder für einige Zeit Beschäftigung bieten. Außerdem ist er deutlich leiser und dank Speedstep & Co dürften auch die Stromkosten etwas sinken. Da allerdings mit der neuen Hardware einige Anschlüsse wegfallen wollte ich eigentlich langsam umsteigen. Erst mal in Ruhe ein aktuelles Gentoo drauf, dann meine Steuerung passend umstellen und schlussendlich dann den alten Server abschalten.
Nunja, das war der Plan, die Praxis kam etwas überraschender. Gerade hatte ich das frische Gentoo auf der neuen Kiste gebootet und eine ellenlange Liste an Portage übergeben gab es als Quittung nur eine Fehlermeldung: Der Portage-Tree wäre ungültig. Huh? Der Tree liegt auf meinem Server und ist per NSF an alle Rechner verteilt – was soll da jetzt auf einmal ungültig sein. Die Antwort war nicht sehr erfreulich: Mein alter Server hatte den Dienst quittiert. Offenbar waren die frostigen Temperaturen zu viel für eine LAN-Karte, die nun den ganzen PCI-Bus lahmlegte. Naja, also die große Auswahl: Weiter arbeiten ohne Internet und mit “lediglich” 100MBit/s im LAN oder direkt den neuen Server fertig aufsetzen. Naja, dir Grundfunktionen sollte der Neuling packen – Routing steckt in einer VM und zur Steuerung reicht PHP. PHP ist schon drauf, also Platten und Karten umgebaut und gestartet. Schnell noch VMware installieren – ach halt. Kein Internet. Auf den alten Platten lagen natürlich auch die Distfiles und somit eine passende Version des VMware Servers. Installiert, Konfiguriert, Gestartet, Connected, … nichts. Keine Reaktion. Hier macht sich der große Nachteil von Closed Source bemerkbar: Debuggen Fehlanzeige. “Es ist ein Fehler aufgetreten – der Fehler lautet:” – nunja, kein Fehler ist auch ein Fehler.

OK, also den VMware-Server auf meinem Laptop installiert und notdürftig den Router zum Booten verholfen. Im Netz auch nichts Neues. Viele kennen den Fehler, nur eine Antwort sucht man vergebens. Mein erster Gedanke war nun direkt auf KVM zu setzen, da dies inzwischen sogar PCI-Karten an VMs weitergeben kann lässt sich damit viel Zeit vertreiben. Dummerweise unterstützen die CPUs keine Hardwarevirtualisierung, womit nur QEmu übrig bliebe. QEmu ist die Lösung, die mir schon öfter Offline-Tage beschert hatte, weil der Netzwerkstack nicht immer so will wie ich. Dann kam mir wieder VMware in den Sinn – die Version 2 des Servers ist seit kurzem stable, im entsprechenden VMware-Overlay fand sich auch schon ein passendes Ebuild und siehe da: Nach etwas gebastel startet sogar das neue Webinterface. OK, ich musste zwar den halben Laptop neu kompilieren, weil das Plugin nur mit USE=”accessibility” funktioniert, aber immerhin konnte ich danach meine zwischenzeitlich neu geladene Version von Endian in eine serverseitige VM bannen.

Nächste Baustelle war meine Steuerung. Die Relaiskarte mit serieller Schnittstelle lässt sich ja noch recht einfach zur Zusammenarbeit überreden, bei meinen Schaltergebastel am Parallelport ist das schon schwerer: Zwar ist das Ganze prinzipiell auch mit dem neuen Server möglich, aber der Parallelport ist hier nur intern auf einem Pfostenstecker ausgeführt. Dumm, wenn man seinerzeit neben den Drähten auch die nötigen Widerstände direkt auf den Sub-D-Stecker gepflastert hat. Als Lösung muss wie immer der Holzhammer her: Jetzt pollt ein kleiner Atmega8 die Schalter und gibt die Daten seriell an den Server weiter. Als kleiner Bonus fragt der in der Leerlaufzeit noch meine 1wire-Thermometer ab, sodass ich trotz der Blockade beider COM-Ports nicht auf die Temperaturen verzichten muss. Auf Dauer auch keine Lösung, dafür habe ich wie schon erwähnt andere Pläne: Nachdem ich während dem Kompilieren etwas mit meinem AVR-Zeugs gebastelt habe konnte ich die ersten beiden MCP2515, trotz der von mir gehasstem SMD-Bauweise, zum reden bringen. Das ganze war so stabil, dass jetzt direkt ein kleines Paket mit MCP2515s zu mir unterwegs ist (diesmal in DIP). Dabei sind auch ein paar weitere Atmega’s – u.A. passend für einen iSysBus Devnode.

Inzwischen geht also sogar das Licht an, wenn ich den Schalter betätige und “mein” Internet ist wie auch die Datenfreigaben zurück auf dem Schirm. Einzige dringende Problemstelle ist das Soundsystem: Meine alte Soundkarte lässt sich nicht in den neuen Slot prügeln – die Karte besteht auf ihre 5V Versorgungsspannung, mein Server hält nur Slots für 3,3V bereit. Schlecht, wenn der Server normal als Wecker dient: Zwar sollte mein Handy hier temporär ausreichen, aber irgendwie ist das nicht immer laut genug :/. Naja, ich mach mich dann auf die Suche nach einer passenden Soundkarte, aber erst mal begebe ich mich jetzt wieder an meinen Terminkalender: Die ersten Konzerttermine für 2009 zeichnen sich ab um zwischen Weihnachten und Neujahr war ja auch noch Etwas.

Mediacenter Zwischenstand II

Ein Schritt weiter und zwei zurück – so ähnlich komme ich mir momentan bei meinem Mediacenter vor. Zum einen hat sich am Interface wieder was getan: Die Zimmersteuerung (Licht u.Ä.) lässt nun über eine virtuelle 3D-Ansicht des Zimmers kontrollieren, Videos haben dank Amazon noch bessere Cover und ein Feedreader im Iframe rückt immerhin ein paar Nachrichten raus. Systemmäßig läuft das Frontend auf einem alten Laptop – theoretisch. Zwar zeigen sich selbst hochauflösende Inhalte und DVDs nun ohne Ruckler, aber die Anbindung von Touchscreen und die Energieverwaltung mit TuxOnIce und Wake on LAN sind alles andere als zuverlässig – zudem erschweren Probleme mit Pulseaudio die Anbindung an mein Soundsystem. Sofern ich mir den neuen Server hole wird wohl dieser wieder dran glauben müssen.

Bei den Sensoren sieht es ähnlich aus: Zwar ist die Hardware für mein Rauch- und Temperaturmeldesystem am Bildschirm soweit fertig, aber irgendwie bekomme ich das Aufbügeln für die Prototyp-PCBs nicht mehr hin (hat Reichelt neues Papier?). Tja, leider sind Softwaresimulationen oder Steckboardgebastel nicht wirklich zuverlässig, daher siehts Softwaremäßig hier noch recht dünn aus.

Etwas besser sieht es bei den Planungen aus das Steuersystem auf meine zukünftige Wohnung auszudehnen – Hier ist die derzeit eingesetzte parallele Signalisierung zum Server natürlich fehl am Platz. Bei meinen Recherchen zum Thema Hausbus bin ich bereits vor längerem beim iSysBus gelandet, einem offenen Projekt, welches auf CAN basiert. Zwar ist die Seite nicht gerade aktuell, aber im IRC und auf dem SVN-Server wird fleißig gewerkelt: Die ersten Node-Prototypen wurden in den letzten Wochen gefertigt und werden momentan von den Aktiven auf µC und Interrupts geprüft. Wenn das ganze für mich aktuell wird hat der Bus recht gute Chancen: CAN ist weit verbreitet und sehr robust, also gut geeignet für eine solche Steuerung. Zudem verwendet iSysBus ebenfalls meine Lieblinge aus der AVR-Serie, was mir bei der Wartung sehr entgegen kommt.

btw: Woran merkt man, dass man sich schon an eine Haussteuerung gewöhnt hat? Wenn man im Büro bei Dämmerungsbeginn instinktiv mit der Maus auf die Stelle im Panel klickt, an der zu Hause der “Licht einschalten”-Button sitzt. Schade, es war dummerweise nur Firefox.

Upgradezeit

Schon seit Jahren fast unveränderte Systeme, da musste es ja so weit kommen: Ich kratze momentan nahezu dauerhaft an allen Leistungskanten meiner Infrastruktur. In den letzten Tagen habe ich mich mal nach Verbesserungsmöglichkeiten umgeschaut.

Erster Problemfall ist meine Internetverbindung – Webradio, Updates, Podcasts und mein in ständig neuen Linux-ISOs resultierender Bastelwahn sorgen für so einige Engpässe auf meiner Leitung. Leider ist hier fürs erste keine Abhilfe in Sicht: Über Telefon ist nicht mehr als die vorhandenen 2MBit/s drin und der lokale Kabelanbieter beschneidet laut meinem letzten Gespräch mit der Hotline seine 10MBit/s-Verbindung per (Un)Fair-Use auf 50GB/Monat – die übertrumpfe ich mit 2MBit/s schon locker.. Hier würde wohl nur ein zusätzlicher Telefonanschluss helfen, aber das ist mir dann sowohl von den Kosten als auch von den hier nötigen Umbauten zu aufwändig.

Der zweite Knackpunkt ist mein Server: “4 CPUs mit je 550MHz, 1GB RAM und vorallem reichlich freie PCI- und COM-Schnittstellen dürften einige Zeit reichen.” – So lauteten meine Worte zum FSC Primergy N70-40 vor ca. 2 Jahren. Nunja, inzwischen ist trotz Erweiterung auf 4GB RAM auch seine Zeit gekommen – Haussteuerung und LUKS skalieren auf mehren Kernen nicht so berauschend und die Plattenkapazität nährt sich dank den ständigen wachsenden Backups meier Seiten, meiner Bildergallerie und dem sonstigem Kram auch stetig der Kapazitätsgrenze – bis zum Jahresende ist hier wohl ein Eingriff notwendig. Da die Kiste ohnehin schon bis ans Maximum aufgerüstet ist muss notgedrungen etwas neues her. Momentan liebäugle ich mit einem FSC Primergy TX-300. Zwar wird es definitiv nicht die Maximalausstattung mit 8 Kernen und 64GB RAM, aber etwas Luft nach oben kann nicht schaden. Dual 10/100/1000er LAN onboard, der angeblich niedrigere Stromverbrauch und die beworbene Linux-Kompatibilität habens mir auf jeden Fall angetan. Was mich momentan noch stört sind die Ports: Fast alle Ports sind PCIx, sodass meine PCI-Karten getauscht werden müssen. Zwar können einige wegfallen, da der “Neue” die Funktionen bereits mitbringt, aber ISDN, Sound, LAN und evtl. SATA müssen wohl irgendwie auf PCIx. Immerhin wäre hier was zu reißen.

Letzter Punkt auf meiner Liste ist mein Rootserver – inzwischen auch ein paar Jahre alt. Zwar läuft die Kiste ganz OK, aber zum Einen sind die Ausfälle des Hosters etwas störend (vorallem wenn er sie danach leugnet) und der Preis ist für das Hardwarealter auch nicht mehr angemessen. Leider schlagen mir hier immernoch die AGBs der ISPs auf dem Magen – IRC/P2P/…-Verbote, Kündigung bei DoS (man ist ja selber Schuld) & Co finde ich zum Teil doch lachhaft… Mal schaun was sich da noch machen lässt.

Ob ich letztendlich den/die Server kaufe weiß ich noch nicht, sollte aber jemand Interesse an einem meiner jetzigen Systemen haben bitte anschreiben, würde mir im Falle eines Austauschs die eBay-Gebühren sparen:

System1:

  • Compaq ProLiant 1850R
  • 2×500MHz
  • 512MB RAM (eventuell mehr, hab noch ein paar SD-ECCs in der Wühlkiste)
  • keine Platten
  • 10/100er LAN
  • Floppy
  • IDE Slimline CD
  • Ältere Bilder: [1] [2] (Inzwischen wie erwähnt 2. CPU und ohne Platten)

System2:

  • Primergy N70-40
  • 4x550MHz
  • 4GB RAM
  • 10/100er LAN
  • 3xPCI (z.T. Hotplug)
  • 1xPCI/ISA
  • 4 PCI 64Bit (Hotplug)
  • 4xCOM
  • 1xCAN
  • 1xUSB
  • 1xPrallel
  • Eventuell mit Festplatten (10-30GB, SCSI, 10kRPM) möglich, Cages auf jeden Fall alle dabei
  • Dual PSU
  • SCSI-CD
  • Floppy
  • HotPlug Dual CPU-Fan 120mm
  • Hinweis: Im inneren ist genug Platz um ein gut gekühltes SATA-Raid (4Platten) zu verstauen 😉
  • Bilder: [1] [2]

Beide Systeme liefen prinzipiell mit Gentoo und sind solide aufgebaut (nicht so dünnes Blechzeugs wie die aktuellen) – eignen sich also auch als überdimensionaler Briefbeschwerer für Nerds :p

Wah – Festplatten…

Mit Festplatten komme ich irgendwie nicht auf einen grünen Zweig. Am laufenden Band verrecken die Dinger und wehe man schaut sie schief an. Los ging das ganze auf der Arbeit mit einem etwas langsam laufenden RAID. Nunja, hätte der Hersteller der Kiste mal eine Fehler-LED gegönnt würde schneller auffallen, dass sich eine Platte verabschiedet hat. Naja, Ersatz rein, rebuild gestartet und das ganze mal irgendwie ins Monitoring aufgenommen. Harmloses Plattenproblem. Weiter direkt zu Hause – nach dem letzten Ubuntu-Upgrade, was ich Gestern auf dem Rechner meiner Eltern eingespielt hatte startete das Ding nicht mehr. Kein Ebay? Da ist meine Mutter schnell auf der Matte und verlangt nach Abhilfe. Schuld waren die bösen Kernel-Maintainer, der ide=nodma-Parameter wird vom aktuellen Ubuntu-Kernel offenbar ignoriert und der DMA-Modus von der Platte mit Arbeitsverweigerung quittiert. Dank neuem IDE-Kabel, ein paar umgebastelten Jumpern und frischem GRUB läuft das ganze jetzt wieder und dank DMA wohl auch etwas schneller. Momentan sitze ich am PC eines Freundes, ebenfalls Plattenschaden, auch wenn diese bei ihm etwas länger durchgehalten hat. Nunja, freundlich wie ich bin habe ich ihn natürlich gleich darauf hingewiesen, dass eine 250GB-Platte nur ein paar Euro teurer ist als die von ihm angedachte 80er. Angekommen ist die nun auch, aber ich hätte mal an das Alter denken sollen – zwar erkannte mein Gentoo-USB-Stick alles korrekt, bei näherem Blick im BIOS war aber bei 128GB Schluss. Crap. Immerhin gibts auf der Medion-Seite ein passendes BIOS-Update, welches mittels FreeDOS inzwischen die 250GB im BIOS anzeigt, lediglich Windows weigert sich noch standhaft die Größe anzuerkennen (und meinen USB-Stick als C:\ zu betrachten) – afair kam die Unterstützung für >128GB erst mit SP1/2, also dürfte jetzt erst mal Install-CD-Erstellen angesagt sein, ich hoff mal, dass es so Tools wie nLite noch gibt :o.

Kaskadierung von Digitus KVM-Switches

Auch wenn sie zu den günstigeren Geräten gehören: KVM-Systeme der Firma Digitus laufen stabil und bieten einen brauchbaren Funktionsumfang. Inzwischen ist mein IC814I-MC etwas zu klein geworden, ein IC812I-MC soll zusätzlich mithelfen. Kaskadieren der KVM-Switches ist ohnehin kein Problem, da die frontseitigen Umschaltknöpfe ohnehin unabhängig sind. Inzwischen habe ich herausgefunden, dass auch die Tastaturumschaltung funktioniert:

Gehen wir von folgendem Aufbau aus:

Möchte man auf einen PC der Gruppe b umschalten kann die bisherige Syntax beibehalten werden, so schaltet z.B. 2xNum+F2 auf den PC B2 um. Da KVM2 direkt mit der Tastatur verbunden ist lassen sich alle Befele wie gewohnt nutzen. Um auf auf PCs an KVM1 zuzugreifen ist eine Angabe mehr notwendig
Drückt man 2xNum+F1 wird KVM2 auf den ersten Anschluss umgeschaltet, jedoch wird nach dem betätigen von F1 nicht wie gewohnt der Befehlsmodus beendet (Keyboard-LEDs blinken), sondern man befindet sich nun im Befehlsmodus des KVM1.

Getestet habe ich das ganze mit IC814I-MC, IC812I-MC und OC12, wobei der 4er immer mit der Tastatur verbunden war.

Eine andere Möglichkeit wäre es am primären Switch die Umschaltfunktion der Ctrl-Tasten abzuschalten, so kann man Num für KVM2 und Ctrl für KVM1 nutzen.