[Gentoo] Apache 2.4.26 + WordPress: Invalid post type

Hmk? After the latest system updates on Gentoo I noticed WordPress was no longer able to open any kind of post list (“invalid post type”), edit posts (you do not have access to this kind of post) or create posts (form shown, but right sidebar missing). Not quite uncommon, but this time it was no broken plugin – I could reproduce the same behavior with several other WordPress instances with different versions – even a fresh install. That’s a new one.

After some probing around I’m fairly certain Apache 2.4.26 is the culprit, after downgrading to 2.4.25 the problem disappeared. All other downgrades like PHP 7.0.15 instead of PHP 7.0.19 didn’t show any effect. I yet have to confirm which combination ultimately triggers the error (FPM? Event-MPM?), but if you have similar errors: Here is your starting point…

4 Gedanken zu „[Gentoo] Apache 2.4.26 + WordPress: Invalid post type“

  1. I use a FreeBSD server with PHP 5.6.30 and Apache. If I upgrade from Apache 2.4.25_1 to 2.4.26, then my admin of Joomla and WordPress sites will be error. Downgrade Apache and no problem.
    I don’t no why.

  2. I had the same issue on FreeBSD – I deleted the latest update:
    pkg delete apache24-2.4.26

    and than reinstalled the older version from the /var/cache/pkg/ folder with
    pkg add apache24-2.4.25_1-7618027f94.txz

    This did affect all WordPress installations and all post types on that system.

Schreibe einen Kommentar zu Bobek Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht.